#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.* ((?:([12])|(3)|([45]))\d{4}) .*"
Local $sString = "Blah 12345 Blah" & @CRLF & _
"Blah 22345 Blah" & @CRLF & _
"Blah 32345 Blah" & @CRLF & _
"Blah 42345 Blah" & @CRLF & _
"Blah 52345 Blah"
Local $sSubst = "(?2AAA:(?3BBB:XYZ))$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)