import Foundation
let pattern = #"^.* ((?:([12])|(3)|([45]))\d{4}) .*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Blah 12345 Blah
Blah 22345 Blah
Blah 32345 Blah
Blah 42345 Blah
Blah 52345 Blah
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"(?2AAA:(?3BBB:XYZ))$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)