package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.* ((?:([12])|(3)|([45]))\d{4}) .*`)
var str = `Blah 12345 Blah
Blah 22345 Blah
Blah 32345 Blah
Blah 42345 Blah
Blah 52345 Blah`
var substitution = "(?2AAA:(?3BBB:XYZ))$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}