# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|\s)#(\w+)//g;t' <<< "#life random string #life
#apple ##apple
#apple#fruit
#life #oranges #fruits #sandwiches #fruit"