import re
regex = re.compile(r"(^|\s)#(\w+)")
test_str = ("#life random string #life \n"
"#apple ##apple\n\n"
"#apple#fruit\n"
"#life #oranges #fruits #sandwiches #fruit")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)