const regex = /(^|\s)#(\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\s)#(\\w+)', 'g')
const str = `#life random string #life
#apple ##apple
#apple#fruit
#life #oranges #fruits #sandwiches #fruit`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);