// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^|\s)#(\w+)").unwrap();
let string = "#life random string #life
#apple ##apple
#apple#fruit
#life #oranges #fruits #sandwiches #fruit";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}