re = /(^|\s)#(\w+)/
str = '#life random string #life
#apple ##apple
#apple#fruit
#life #oranges #fruits #sandwiches #fruit'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result