import Foundation
let pattern = ##"(^|\s)#(\w+)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ###"""
#life random string #life
#apple ##apple
#apple#fruit
#life #oranges #fruits #sandwiches #fruit
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)