#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(^|\s)#(\w+)"
Local $sString = "#life random string #life " & @CRLF & _
"#apple ##apple" & @CRLF & _
"" & @CRLF & _
"#apple#fruit" & @CRLF & _
"#life #oranges #fruits #sandwiches #fruit"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)