use strict;
my $str = '#life random string #life
#apple ##apple
#apple#fruit
#life #oranges #fruits #sandwiches #fruit';
my $regex = qr/(^|\s)#(\w+)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";