# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<\?=)
(
(
(?!
(htmlspecialchars|htmlentities|json_encode)
)
.
)*
[\$]{1,}
(.*)
)
(\?>)/purify($2)/gix;t' <<< "<?= $lorem ?>
<?= _($lorem) ?>
<?= 'ipsumz' ?>
<?= _('ipsum') ?>
//Conditions ternaires
<?= ($a == $b) ? 'lorem' : 'ipsum' ?>
//Chaînes contenant un htmlspecialchars()
<?= 'lorem ' . htmlspecialchars('lorem ipsum') ?>
//Chaînes contenant un htmlentities()
<?= htmlentities('lorem ipsum') ?>"