const regex = /(<\?=)
(
(
(?!
(htmlspecialchars|htmlentities|json_encode)
)
.
)*
[\$]{1,}
(.*)
)
(\?>)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\?=)
(
(
(?!
(htmlspecialchars|htmlentities|json_encode)
)
.
)*
[\\$]{1,}
(.*)
)
(\\?>)', 'gi')
const str = `<?= \$lorem ?>
<?= _(\$lorem) ?>
<?= 'ipsumz' ?>
<?= _('ipsum') ?>
//Conditions ternaires
<?= (\$a == \$b) ? 'lorem' : 'ipsum' ?>
//Chaînes contenant un htmlspecialchars()
<?= 'lorem ' . htmlspecialchars('lorem ipsum') ?>
//Chaînes contenant un htmlentities()
<?= htmlentities('lorem ipsum') ?>`;
const subst = `purify($2)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);