use strict;
my $str = '<?= $lorem ?>
<?= _($lorem) ?>
<?= \'ipsumz\' ?>
<?= _(\'ipsum\') ?>
//Conditions ternaires
<?= ($a == $b) ? \'lorem\' : \'ipsum\' ?>
//Chaînes contenant un htmlspecialchars()
<?= \'lorem \' . htmlspecialchars(\'lorem ipsum\') ?>
//Chaînes contenant un htmlentities()
<?= htmlentities(\'lorem ipsum\') ?>';
my $regex = qr/(<\?=)
(
(
(?!
(htmlspecialchars|htmlentities|json_encode)
)
.
)*
[\$]{1,}
(.*)
)
(\?>)/ixp;
my $subst = 'purify($2)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";