re = /(<\?=)
(
(
(?!
(htmlspecialchars|htmlentities|json_encode)
)
.
)*
[\$]{1,}
(.*)
)
(\?>)/ix
str = '<?= $lorem ?>
<?= _($lorem) ?>
<?= \'ipsumz\' ?>
<?= _(\'ipsum\') ?>
//Conditions ternaires
<?= ($a == $b) ? \'lorem\' : \'ipsum\' ?>
//Chaînes contenant un htmlspecialchars()
<?= \'lorem \' . htmlspecialchars(\'lorem ipsum\') ?>
//Chaînes contenant un htmlentities()
<?= htmlentities(\'lorem ipsum\') ?>'
subst = 'purify($2)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result