// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ix)(<\?=)
(
(
(?!
(htmlspecialchars|htmlentities|json_encode)
)
.
)*
[\$]{1,}
(.*)
)
(\?>)").unwrap();
let string = "<?= $lorem ?>
<?= _($lorem) ?>
<?= 'ipsumz' ?>
<?= _('ipsum') ?>
//Conditions ternaires
<?= ($a == $b) ? 'lorem' : 'ipsum' ?>
//Chaînes contenant un htmlspecialchars()
<?= 'lorem ' . htmlspecialchars('lorem ipsum') ?>
//Chaînes contenant un htmlentities()
<?= htmlentities('lorem ipsum') ?>";
let substitution = "purify($2)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}