#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(@imgBack:\s*#)(?:\d+)(.*)$"
Local $sString = "@background: #345602;" & @CRLF & _
"@imgBack: #0000;" & @CRLF & _
""
Local $sSubst = "$1#ff0000$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)