import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(@imgBack:\\s*#)(?:\\d+)(.*)$";
final String string = "@background: #345602;\n"
+ "@imgBack: #0000;\n";
final String subst = "$1#ff0000$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}