$re = '/(@imgBack:\s*#)(?:\d+)(.*)$/m';
$str = '@background: #345602;
@imgBack: #0000;
';
$subst = "$1#ff0000$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;