use strict;
my $str = '@background: #345602;
@imgBack: #0000;
';
my $regex = qr/(@imgBack:\s*#)(?:\d+)(.*)$/mp;
my $subst = '$1#ff0000$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";