using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(@imgBack:\s*#)(?:\d+)(.*)$";
string substitution = @"$1#ff0000$2";
string input = @"@background: #345602;
@imgBack: #0000;
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}