import Foundation
let pattern = ##"(@imgBack:\s*#)(?:\d+)(.*)$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
@background: #345602;
@imgBack: #0000;
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"$1#ff0000$2"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)