re = /(@imgBack:\s*#)(?:\d+)(.*)$/m
str = '@background: #345602;
@imgBack: #0000;
'
subst = '$1#ff0000$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result