// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(@imgBack:\s*#)(?:\d+)(.*)$").unwrap();
let string = "@background: #345602;
@imgBack: #0000;
";
let substitution = "$1#ff0000$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}