const regex = /(@imgBack:\s*#)(?:\d+)(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(@imgBack:\\s*#)(?:\\d+)(.*)$', 'gm')
const str = `@background: #345602;
@imgBack: #0000;
`;
const subst = `$1#ff0000$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);