# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(About.*)<br\\/>$/<b>$1<\/b><br\/>/gm;t' <<< "<br/>
About Company Name<br/>
<p>This is just some random text About nothing.</p>
<br/>"