const regex = /^(About.*)<br\/>$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(About.*)<br\\\/>$', 'gm')
const str = `<br/>
About Company Name<br/>
<p>This is just some random text About nothing.</p>
<br/>`;
const subst = `<b>$1</b><br/>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);