# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(https?:\\/\\/[^\s]+)/<a href="\1">Я.Диск<\/a>/g;t' <<< "https://yadi.sk/d/bty6b765b5u5bu6"