package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https?:\/\/[^\s]+)`)
var str = `https://yadi.sk/d/bty6b765b5u5bu6`
var substitution = "<a href="\1">Я.Диск</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}