// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(https?:\/\/[^\s]+)").unwrap();
let string = "https://yadi.sk/d/bty6b765b5u5bu6";
let substitution = "<a href=\"\\1\">Я.Диск</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}