import Foundation
let pattern = #"(https?:\/\/[^\s]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://yadi.sk/d/bty6b765b5u5bu6"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="\1">Я.Диск</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)