const regex = /(https?:\/\/[^\s]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/[^\\s]+)', 'g')
const str = `https://yadi.sk/d/bty6b765b5u5bu6`;
const subst = `<a href="\1">Я.Диск</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);