use strict;
my $str = 'https://yadi.sk/d/bty6b765b5u5bu6';
my $regex = qr/(https?:\/\/[^\s]+)/p;
my $subst = '<a href="\\1">Я.Диск</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";