using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/[^\s]+)";
string substitution = @"<a href=""\1"">Я.Диск</a>";
string input = @"https://yadi.sk/d/bty6b765b5u5bu6";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}