#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(https?:\/\/[^\s]+)"
Local $sString = "https://yadi.sk/d/bty6b765b5u5bu6"
Local $sSubst = "<a href="\1">Я.Диск</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)