# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([a-zA-Z0-9]{1,12})[_]+([a-zA-Z0-9]{1,12})+([a-zA-Z])?([_][r][0-9]{1,3})?[\.].*$/@job = '$1' and @jobPart = '$2' and @version = '$3' and @note = '$4'/;t' <<< "132563_01_r2.jpg"