using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z0-9]{1,12})[_]+([a-zA-Z0-9]{1,12})+([a-zA-Z])?([_][r][0-9]{1,3})?[\.].*$";
string substitution = @"@job = '$1' and @jobPart = '$2' and @version = '$3' and @note = '$4'";
string input = @"132563_01_r2.jpg";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}