import Foundation
let pattern = #"^([a-zA-Z0-9]{1,12})[_]+([a-zA-Z0-9]{1,12})+([a-zA-Z])?([_][r][0-9]{1,3})?[\.].*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"132563_01_r2.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"@job = '$1' and @jobPart = '$2' and @version = '$3' and @note = '$4'"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}