import re
regex = re.compile(r"^([a-zA-Z0-9]{1,12})[_]+([a-zA-Z0-9]{1,12})+([a-zA-Z])?([_][r][0-9]{1,3})?[\.].*$")
test_str = "132563_01_r2.jpg"
subst = "@job = '$1' and @jobPart = '$2' and @version = '$3' and @note = '$4'"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)