import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z0-9]{1,12})[_]+([a-zA-Z0-9]{1,12})+([a-zA-Z])?([_][r][0-9]{1,3})?[\\.].*$";
final String string = "132563_01_r2.jpg";
final String subst = "@job = '$1' and @jobPart = '$2' and @version = '$3' and @note = '$4'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}