const regex = /^([a-zA-Z0-9]{1,12})[_]+([a-zA-Z0-9]{1,12})+([a-zA-Z])?([_][r][0-9]{1,3})?[\.].*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z0-9]{1,12})[_]+([a-zA-Z0-9]{1,12})+([a-zA-Z])?([_][r][0-9]{1,3})?[\\.].*$', '')
const str = `132563_01_r2.jpg`;
const subst = `@job = '$1' and @jobPart = '$2' and @version = '$3' and @note = '$4'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);