use strict;
my $str = '132563_01_r2.jpg';
my $regex = qr/^([a-zA-Z0-9]{1,12})[_]+([a-zA-Z0-9]{1,12})+([a-zA-Z])?([_][r][0-9]{1,3})?[\.].*$/p;
my $subst = '@job = \'$1\' and @jobPart = \'$2\' and @version = \'$3\' and @note = \'$4\'';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";