#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^([a-zA-Z0-9]{1,12})[_]+([a-zA-Z0-9]{1,12})+([a-zA-Z])?([_][r][0-9]{1,3})?[\.].*$"
Local $sString = "132563_01_r2.jpg"
Local $sSubst = "@job = '$1' and @jobPart = '$2' and @version = '$3' and @note = '$4'"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)