# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(https?:\\/\\/[^\s]+?\.[^\s]+)$/<a href="$1">auto link<\/a>/gmi;t' <<< "http://example.com
https://example.com"