$re = '/^(https?:\/\/[^\s]+?\.[^\s]+)$/mi';
$str = 'http://example.com
https://example.com';
$subst = "<a href=\"$1\">auto link</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;