use strict;
my $str = 'http://example.com
https://example.com';
my $regex = qr/^(https?:\/\/[^\s]+?\.[^\s]+)$/mip;
my $subst = '<a href="$1">auto link</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";