#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^(https?:\/\/[^\s]+?\.[^\s]+)$"
Local $sString = "http://example.com" & @CRLF & _
"https://example.com"
Local $sSubst = "<a href="$1">auto link</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)