re = /^(https?:\/\/[^\s]+?\.[^\s]+)$/mi
str = 'http://example.com
https://example.com'
subst = '<a href="$1">auto link</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result