// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(https?:\/\/[^\s]+?\.[^\s]+)$").unwrap();
let string = "http://example.com
https://example.com";
let substitution = "<a href=\"$1\">auto link</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}