const regex = /^(https?:\/\/[^\s]+?\.[^\s]+)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https?:\\\/\\\/[^\\s]+?\\.[^\\s]+)$', 'gmi')
const str = `http://example.com
https://example.com`;
const subst = `<a href="$1">auto link</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);